Questions tagged npm

Explore the latest questions and answers asked by our top developers.

Why I can’t upgrade Angular without peer dependency issues?

I would like to upgrade Angular 12 to 13, but I got a peer dependency issue. How can I fix this type of issues? I strongly followed the official upgrade documentation: https://update.angular.io/?v=12.0-13.0 Package "@nguniversal/builders" has an incompatible peer dependency to "@angular-devkit/build-angular" (requires "^12.1.0", would install "13.0.4"). Source: Angular Questions

By Tutorialwork
Published
Categorized as angular, npm, peer-dependencies, upgrade Tagged , , ,

ERROR WHILE RUNNING ionic serve: [ng] Error: The Angular Compiler requires TypeScript >=4.4.2 and <4.5.0 but 4.5.2 was found instead

I was trying to run the ionic serve command but I keep getting the error [ng] Error: The Angular Compiler requires TypeScript >=4.4.2 and <4.5.0 but 4.5.2 was found instead. When I tried downgrading the typescript using this command npm install [email protected]">=4.4.2 <4.5.0" –save-dev –save-exact And Also running the npm i ; The ionic serve […]

Not Able To Access Properties And Methods After Running ‘npm install –save docx’ In Angular

I am having trouble with getting the docxjs package installed. After running npm install –save docx it gives me a bunch of depreciated warnings: npm WARN deprecated [email protected]: The querystring API is considered Legacy. new code should use the URLSearchParams API instead. npm WARN deprecated [email protected]: this library is no longer supported npm WARN deprecated […]

By Lester
Published
Categorized as angular, node.js, npm, typescript Tagged , , ,

Must use import to load ES Module while updating angular

I ran into this problem while trying to upgrading from angular 6 to 8, whenever i try to ng serve or ng build i get the following error: its been so fustrating, i’ve tried adding the "type":"modules" to my package.json, trying renaming those files with the error to .cjs (then it doesnt even find the […]

By Luis pineda
Published
Categorized as angular, javascript, npm, typescript, upgrade Tagged , , , ,

node_modules/@angular/core/core"’ has no exported member ‘ɵɵFactoryDeclaration’

We are facing issue as mentioned in title. When we are doing ng build than its shows an attached SS error to us. WE have tried all possbile way as already shared in github / stackoverflow community. But still we are facing the same error. Guys, please help us to resolve this issue. We are […]

By RK7002
Published
Categorized as angular, npm Tagged ,

NGCC failed error in Angular 11.x app when running npm run

I have an Angular 11.x app that I run using npm run start – this has worked fine for months but all of a sudden it is no longer running the command and I am getting the following errors, can anyone suggest how I fix this? I have tried the obvious ideas of deleting node_modules […]

By Zabs
Published
Categorized as angular, node.js, npm, npm-start Tagged , , ,

npm ERR! Found: @angular/[email protected] npm ERR! node_modules/@angular/animations npm ERR! @angular/[email protected]"^8.0.0" from the root project

I’m trying to give npm install but at that time it is showing below error, npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: [email protected] npm ERR! Found: @angular/[email protected] npm ERR! node_modules/@angular/animations npm ERR! @angular/[email protected]"^8.0.0" from the root project npm ERR! npm ERR! Could not resolve […]

By Sowmiya B
Published
Categorized as angular, node.js, npm Tagged , ,

Incompatible peer dependecy udpating angular material

i try to update angular material from v6 to v7 with the following command in my project: npx @angular/[email protected] update @angular/[email protected] This does not work due to some incompatible peer dependencies, e.g.: Package "@kolkov/angular-editor" has an incompatible peer dependency to "@angular/common" (requires ">=7.0.0 <8" (extended), would install "13.0.2"). But i don’t understand where this comes […]

By enbma
Published
Categorized as angular, npm Tagged ,

Unable to resolve dependency tree error for running "npm i @angular/cdk" command

I wanted to run this command > npm i @angular/cdk and I’m getting this error : I removed node_modules , ran npm install,npm audit ,npm audit fixand npm i –legacy-peer-deps with no veil. I also updated the "jasmine-core" to "~3.6.0". Angular version:10.1.2 Node version: ‘16.13.0’ NPM version : ‘8.1.4’ npm ERR! code ERESOLVE npm ERR! […]

By Kkaeb song
Published
Categorized as angular, npm Tagged ,

error TS1005: ‘;’ expected after install angular material

I have this problem after install angular material. I already updated typescript global version to latest version. tsc -v = Version 4.5.2 ERROR in node_modules/@angular/material/core/common-behaviors/constructor.d.ts:14:64 – error TS1005: ‘;’ expected. 14 export declare type AbstractConstructor<T = object> = abstract new (…args: any[]) => T; ~~~ node_modules/@angular/material/core/common-behaviors/constructor.d.ts:14:69 – error TS1109: Expression expected. 14 export declare type […]

By Patrick Juan
Published
Categorized as angular, angular-material, npm, typescript Tagged , , ,
1 84

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq