Category : nomachine-nx

I try to migrate from angular 11 to angular 12 using the nx migrate command, but I’ve an error I can’t understand what happens and how to fix it. Basically, when I run nx migrate latest my output is : /Users/USERNAME/Projects/myNxAngular11Project/node_modules/yargs/build/lib/yargs.js:1132 throw err; ^ Error: Command failed: npm install –legacy-peer-deps at checkExecSyncError (child_process.js:635:11) at Object.execSync ..

Read more

currently we have a .env file with the following definitions in the backend of a Nx project HOST=$HOST USER_DB=$USER_DB PASS_DB=$PASS_DB We are using this approach for not hardcoding anything, so we can have that .env file in our repo without any problem. The workflow of the CodePipeline is: Testing/Linting Build image and put it into ..

Read more

Im new to NX, created a library "designsystem-angular-header" that depends on another library "designsystem-angular" When I try to build the compiler goes to the dist folder to search for html files for the dependency? Only there are none, only typescript files … Has anyone had some experience with this? nx run designsystem-angular-header:build:production Building entry point ..

Read more

Used the new ‘convert-tslint-to-eslint’ tool in the latest release of nrwl/nx https://github.com/nrwl/nx/releases/tag/11.6.1 "@nrwl/angular": "11.6.1", "@nrwl/cli": "11.6.1", "@nrwl/cypress": "11.6.1", "@nrwl/eslint-plugin-nx": "^11.6.1", "@nrwl/linter": "11.6.1", "@nrwl/nest": "11.6.1", "@nrwl/node": "11.6.1", "@nrwl/storybook": "11.6.1", "@nrwl/tao": "11.6.1", "@nrwl/workspace": "11.6.1", Got one problem, where i have no idea how to solve this! yarn run v1.22.5 $ nx workspace-lint && yarn run lint:styles && ..

Read more