Search Posts

Category: bower

Getting started with [Wrap]Bootstrap theme with Bower/Grunt

This is my first attempt at using a frontend package that uses Grunt/Bower. I am specifically referring to a Wrapbootstrap theme. I followed the instructions as follows: npm install -g grunt-cli npm install -g bower npm install bower install I believe the process went fine. There were some deprecation warnings though. What I ended up was with a file structure like this: However, now I am lost as how to start. The instructions says to […]

How to set up webpack in AngularJS ASP.NET MVC 5 application?

I have this project currently running on ASP.NET MVC and using AngularJS for the front end. I am using bower and gulp but want to migrate away to use new tooling, if possible webpack. I have started the migration process, where all bower packages have been moved to package.json. I need help figuring out how to set up webpack. And how the changes will affect the .NET Bundle.Config.cs file in App_Start. Basic Project structure: MyApp/ […]

Why can’t gulp-main-npm-files see angular-spinkit?

I am trying to migrate away from bower, which is serving to get the front end vendor packages needed for a project. Currently, I am using the main-bower-files library to grab all of the libraries listed under “dependencies” in bower.json in a gulpfile.js. I am trying to use gulp-main-npm-files as a replacement. To test this, I deleted angular-spinkit from bower.json and used npm-install –save. This created a new field in package.json, “dependencies”, and placed the […]

Migration from grunt to webpack in angular 1.6

I have an existing application in angular 1.6 We are currently using grunt and bower to build the application. Now the requirement came to migrate the existing application to webpack and removing grunt and bower. Anyone can give me the right suggestion , how to approach for the same. I am struggling with entry point, bundle path and the loader I am supposed to put in webpack config. The index.html, which script tags to remove […]

trouble replacing bower/npm with yarn

I should start by saying that that I’m not that experienced with front end tools and frameworks but have done some work with angularjs and jquery, so I’m sorry in advance if I’m asking something obvious and stupid. I’m working on a rails 4 + angularjs(1.2.9) project and it is using bower and npm for package management, the basic folder structure is project |-angular |-app |-components |-angular |-.bower.json |-angular.js |-node modules |-.bowerrc |-.package.json |-component.json |-rails […]

Move from bower to npm and webpack

My app has a MEAN stack (mongodb + express + angular 1 + nodejs). I’m using webpack + npm + bower to build and run, and am trying to shift bower to npm completely. I followed the tutorial here: https://medium.com/netscape/bye-bye-bower-or-how-to-migrate-from-bower-to-npm-and-webpack-4eb2e1121a50 which was quite helpful but I realised my frontend dependencies aren’t getting their dependencies installed, e.g. angular-animate.js complains that angular.js is not found. By following the tutorial above, the way I did it was: Find […]

bower install – fails in Jenkins – with ENOTFOUND error

{ “name”: “concur-frontend”, “version”: “0.0.0”, “dependencies”: { “angular”: “1.5.8”, “bootstrap”: “3.3.7”, “angular-animate”: “1.5.8”, “angular-cookies”: “1.5.8”, “angular-resource”: “1.5.8”, “angular-route”: “1.5.8”, “angular-sanitize”: “1.5.8”, “angular-touch”: “1.5.8”, “angular-ui-router”: “0.3.2”, “lodash”: “3.0.0”, “restangular”: “1.6.1”, “angular-bootstrap”: “1.2.5”, “ui-bootstrap”: “2.5.0”, “angular-spinner”: “0.8.1”, “spin”: “1.1.6”, “bootstrap-ui-datetime-picker”: “2.3.1” }, “devDependencies”: { “angular-mocks”: “^1.4.0” }, “appPath”: “app”, “moduleName”: “meetingApp”, “overrides”: { “bootstrap”: { “main”: [ “less/bootstrap.less”, “dist/css/bootstrap.css”, “dist/js/bootstrap.js” ] } }, “resolutions”: { “angular-bootstrap”: “~1.2.0” } } The above is my bower.json file and i […]

No matching version found for [email protected]^1.1.0 [duplicate]

This question already has an answer here: Error installing Angular using npm due to require-from-string 5 answers Dependencies for npm project: “dependencies”: { “angular-chart.js”: “1.1.0”, “angular-cookies”: “1.5.7”, “angular-ui-bootstrap”: “2.4.0”, “angular-ui-grid”: “4.0.5”, “checklist-model”: “0.10.0”, “json-schema”: “0.2.2” } And npm install stops to work with the following error: npm ERR! code ETARGET npm ERR! notarget No matching version found for [email protected]^1.1.0 npm ERR! notarget In most cases you or one of your dependencies are requesting npm ERR! […]

"UNMET PEER DEPENDENCY" when trying to add bootstrap-ui to my angular

I am trying to install angular-ui I have tried all the commands from the tutorials, including: npm install angular-bootstrap This returns the arror +– UNMET PEER DEPENDENCY [email protected]>=1.5 I checked my angular version and it is 1.4, so I am assuming that is the reason ? I read a tutorial about migrating to 1.5 but it simply says that I should copy the new link to angular.js 1.5, which I did. Still no luck. Source: […]

Next Page »