How to run Angular 12 project using Angular CLI 13

Published

I downloaded an Angular 12 project and I am trying to run it using Angular 13 (latest version). Thus I have problems thrown when I try to run it it. Even if I tried to use npm install, some dependency issues are thrown

Errors thrown when running using ng serve:

Require stack:
- /usr/local/lib/node_modules/@angular/cli/node_modules/@angular-devkit/architect/node/node-modules-architect-host.js
- /usr/local/lib/node_modules/@angular/cli/node_modules/@angular-devkit/architect/node/index.js
- /usr/local/lib/node_modules/@angular/cli/models/architect-command.js
- /usr/local/lib/node_modules/@angular/cli/commands/serve-impl.js
- /usr/local/lib/node_modules/@angular/cli/node_modules/@angular-devkit/schematics/tools/export-ref.js
- /usr/local/lib/node_modules/@angular/cli/node_modules/@angular-devkit/schematics/tools/index.js
- /usr/local/lib/node_modules/@angular/cli/utilities/json-schema.js
- /usr/local/lib/node_modules/@angular/cli/models/command-runner.js
- /usr/local/lib/node_modules/@angular/cli/lib/cli/index.js
- /usr/local/lib/node_modules/@angular/cli/lib/init.js
See "/private/var/folders/w0/wfq3__js19g4lbf33bpkwbrm0000gp/T/ng-hQcZ24/angular-errors.log" for further details.```



I tried to use the npm install, but also some other errors where thrown:



```npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/rxjs
npm ERR!   [email protected]"7.2.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]"^6.5.3" from @angular/[email protected]
npm ERR! node_modules/@angular/core
npm ERR!   @angular/[email protected]"12.1.2" from the root project
npm ERR!   peer @angular/[email protected]"12.1.2" from @angular/[email protected]
npm ERR!   node_modules/@angular/animations
npm ERR!     @angular/[email protected]"12.1.2" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /Users/aless/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:```


Any help please ?

Source: Angular Questions

Published
Categorized as angular, angular12, angular13, node.js, npm Tagged , , , ,

Answers

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Still Have Questions?


Our dedicated development team is here for you!

We can help you find answers to your question for as low as 5$.

Contact Us
faq