Ionic 5 – API request working on browser, not on emulated IOS

I have this Ionic 5/Capacitor app, which I’m making an API call to a local server from, that server running on docker at localhost:3000. When I test from the browser, the request is made fine. From Postman it requests fine, too. In my XCode logs the emulator, I see this

[error] - ERROR {"headers":{"normalizedNames":{},"lazyUpdate":null,"headers":{}},"status":0,"statusText":"Unknown Error","url":"http://localhost:3000/pins","ok":false,"name":"HttpErrorResponse","message":"Http failure response for http://localhost:3000/pins: 0 Unknown Error","error":{"isTrusted":true}}

The really interesting part, is that I’m running Fiddler to monitor the request as it’s made. Fiddler gets a 200 as well, I can even see the response data. So, Fiddler sees the proper network call, but then my Ionic app gets that error. That makes me feel like it’s an Ionic/Emulator/IOS problem, but I don’t have enough familiarity with Ionic to know right off the bat what it is.

Here’s the code responsible for making the request:

  ngOnInit() {
    const request = this.http.get('http://localhost:3000/pins');

    this.refresh$.subscribe(
      (lastPos: { latitude?: any; longitude?: number }) => {
        request.subscribe(data => {
          if (data) {
            this.addMarkersToMap(data, lastPos);
          }
        });
      }
    );
  }

And the HTTPClient imported in the constructor is from Angular:

import { HttpClient } from '@angular/common/http';

Source: Angular Questions