Error: The Angular Compiler requires TypeScript >=4.0.0 and <4.1.0 but 4.1.2 was found instead

While migrating and existing app to Angular 11, I’m facing the following error:

Error: The Angular Compiler requires TypeScript >=4.0.0 and <4.1.0 but 4.1.2 was found instead.

I’m not sure from where the 4.1.2 dependency is coming. Running the tsc from the global installation returns 4.0.5:

tsc --version
Version 4.0.5

Running the local version returns the same value:

npx tsc –version
Version 4.0.5

I know that I can disable the TS version checking, but I’d really love to know from where that 4.1.2 version is coming from.

Ideas?

Source: Angular Questions