While updating angular project from 9.1.12 to 10.1.0, It is giving an error

An unhandled exception occurred: npm WARN deprecated [email protected]:
request has been deprecated, see
https://github.com/request/request/issues/3142 npm WARN deprecated
[email protected]: this library is no longer supported
internal/modules/cjs/loader.js:968

enter image description here

Source: Angular Questions