Angular: Upgrading to version 8 error: Version of @angular/compiler-cli needs to be 2.3.1 or greater. Current version is "8.2.14 "

Unable to solve this error

Angular cli – 9.1.7
Angular compiler cli – 8.2.14

Kindly suggest.

Source: New feed
Source Url Angular: Upgrading to version 8 error: Version of @angular/compiler-cli needs to be 2.3.1 or greater. Current version is "8.2.14 "