Am I going to face problems If I keep working on my Angular project while it shows warning message (requires [email protected]’>=2.7.0 <2.8.0′)?

I am not able to solve the problem that is caused by the wrong version of typescript. When I run ng serve, I see this warning message:
@angular/[email protected] requires [email protected]’>=2.7.0 <2.8.0′ but 2.8.4 was found instead.

I tried many solutions and I failed to solve it. I want to continue working on my project until I find a solution. Would it be difficult to solve it later on? Would it cause other problems in my project?

Source: New feed
Source Url Am I going to face problems If I keep working on my Angular project while it shows warning message (requires [email protected]’>=2.7.0 <2.8.0′)?