ng add @angular/material broke my angular project

I tried to install angular material into my angular project and threw the following error. Now my project wont compile and throws a ton of errors:

$ ng add @angular/material
Your global Angular CLI version (8.2.1) is greater than your local
version (6.0.8). The local Angular CLI version is used.

To disable this warning use "ng config -g cli.warnings.versionMismatch false".
Installing packages for tooling via npm.
npm WARN [email protected] requires a peer of [email protected]^1.14.7 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/[email protected] requires a peer of @angular/[email protected]^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/[email protected] requires a peer of @angular/[email protected] but none is installed. You must install peer dependencies yourself.
npm WARN @angular/[email protected] requires a peer of @angular/[email protected]^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/[email protected] requires a peer of @angular/[email protected]^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/[email protected] requires a peer of @angular/[email protected]^8.0.0 || ^9.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modulesfsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ @angular/[email protected]
added 1 package and audited 23557 packages in 9.172s
found 372 vulnerabilities (2 low, 15 moderate, 355 high)
  run `npm audit fix` to fix them, or `npm audit` for details
Installed packages for tooling via npm.
Schematics/alias "install" collides with another alias or schematic name.
Error: Schematics/alias "install" collides with another alias or schematic name.
    at NodeModulesEngineHost.createCollectionDescription (C:[email protected]ystem-engine-host-base.js:125:27)
    at SchematicEngine._createCollectionDescription (C:[email protected]gine.js:78:40)
    at SchematicEngine.createCollection (C:[email protected]gine.js:71:43)
    at Object.getCollection (C:[email protected]:28:31)
    at AddCommand.getOptions (C:[email protected]s:193:41)
    at AddCommand.<anonymous> (C:[email protected]:30:49)
    at Generator.next (<anonymous>)
    at C:[email protected]:7:71
    at new Promise (<anonymous>)
    at __awaiter (C:[email protected]:3:12)

When I try to ng serve i get the following
$ ng serve -o
Your global Angular CLI version (8.2.1) is greater than your local
version (6.0.8). The local Angular CLI version is used.

To disable this warning use "ng config -g cli.warnings.versionMismatch false".
** Angular Live Development Server is listening on localhost:4200, open your browser on http://localhost:4200/ **

Date: 2019-08-14T23:24:01.693Z
Hash: eb17c9d00c81b8151009
Time: 5221ms
chunk {main} main.js, main.js.map (main) 2 kB [initial] [rendered]
chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 717 bytes [initial] [rendered]
chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]
chunk {scripts} scripts.js, scripts.js.map (scripts) 142 kB  [rendered]
chunk {styles} styles.css, styles.css.map (styles) 163 kB [initial] [rendered]
chunk {vendor} vendor.js, vendor.js.map (vendor) 325 kB [initial] [rendered]

ERROR in ../../node_modules/@angular/material/button-toggle/typings/button-toggle.d.ts(181,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/button/typings/button.d.ts(32,44): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/checkbox/typings/checkbox.d.ts(142,43): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/chips/typings/chip-input.d.ts(66,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/chips/typings/chip-list.d.ts(203,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/chips/typings/chip-list.d.ts(205,27): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/chips/typings/chip-text-control.d.ts(19,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/expansion/typings/expansion-panel-header.d.ts(55,43): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/input/typings/input.d.ts(108,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/list/typings/selection-list.d.ts(138,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/menu/typings/menu-item.d.ts(36,43): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/menu/typings/menu-trigger.d.ts(103,43): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/radio/typings/radio.d.ts(198,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/select/typings/select.d.ts(334,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/slide-toggle/typings/slide-toggle.d.ts(109,21): error TS2304: Cannot find name 'FocusOptions'.
../../node_modules/@angular/material/slider/typings/slider.d.ts(87,21): error TS2304: Cannot find name 'FocusOptions'.

i 「wdm」: Failed to compile.

Here is my ng -v

$ ng -v
Your global Angular CLI version (8.2.1) is greater than your local
version (6.0.8). The local Angular CLI version is used.

To disable this warning use "ng config -g cli.warnings.versionMismatch false".

Angular CLI: 6.0.8
Node: 10.16.2
OS: win32 x64
Angular: 6.1.10
... animations, common, compiler, compiler-cli, core, forms
... http, platform-browser, platform-browser-dynamic
... platform-server, router

Package                           Version
-----------------------------------------------------------
@angular-devkit/architect         0.6.8
@angular-devkit/build-angular     0.6.8
@angular-devkit/build-optimizer   0.6.8
@angular-devkit/core              0.6.8
@angular-devkit/schematics        0.6.8
@angular/cdk                      8.1.3
@angular/cli                      6.0.8
@angular/language-service         6.0.5
@angular/material                 8.1.3
@ngtools/webpack                  6.0.8
@schematics/angular               0.6.8
@schematics/update                0.6.8
rxjs                              6.2.1
typescript                        2.7.2
webpack                           4.8.3

Project was compiling and running fine with the different CLI versions before I ran the add command.

Can’t seem to find any similar issues.

I have tried re adding angular/material but the same issue.

Source: New feed
Source Url ng add @angular/material broke my angular project