How can I get Protractor v5 to work with JDK 1.7?

Is there a way to run the latest Protractor (v5.1.2) with Java 7?

I see the following error when I start up webdriver-manager.

I would prefer not to downgrade Protractor, but at this point, I’m desperate.

[10:15:04] I/start - java -Dwebdriver.chrome.driver=C:Usersx12345codemy-protractor-appnode_modulesprotractornode_moduleswebdriver-managerseleniumchromed
river_2.33.exe -Dwebdriver.gecko.driver=C:Usersx12345codemy-protractor-appnod
e_modulesprotractornode_moduleswebdriver-managerseleniumgeckodriver-v0.19.0
.exe -jar C:Usersx12345codemy-protractor-appnode_modulesprotractornode_modu
leswebdriver-managerseleniumselenium-server-standalone-3.6.0.jar -port 4444
[10:15:04] I/start - seleniumProcess.pid: 12752
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/openqa/gr
id/selenium/GridLauncherV3 : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)

Source: AngularJS